Skip to main content

Reverse String Wordwise

Question: 

Reverse the given string word wise. That is, the last word in given string should come at 1st place, last second word at 2nd place and so on. Individual words should remain as it is.

Input format :
String in a single line
Output format :
Word wise reversed string in a single line
Constraints :
0 <= |S| <= 10^7
where |S| represents the length of string, S.
Sample Input 1:
Welcome to Coding Ninjas
Sample Output 1:
Ninjas Coding to Welcome

Ans: package learningJava;

import java.util.*;

/**

* This program demonstrates a function to reverse words in a given string.

* It takes a string as input and reverses the order of words in the string.

*/

public class regPract {


/**

* Reverses the order of words in a given string.

*

* @param end The ending index of the input string.

* @param start The starting index for extracting a word.

* @param j An index variable used in loops.

* @param input The input string to reverse.

* @return The reversed string.

*/

public static String reverseString(int end, int start, int j, String input) {

String result = "";

String word = "";

// Traverse the input string from right to left.

for (int i = input.length() - 1; i >= 0; i--) {

if (input.charAt(i) == ' ') {

// When a space is encountered, extract and reverse a word.

start = i + 1;

word = "";

for (j = start; j <= end; j++) {

word += input.charAt(j);

}

end = i - 1;

result = result + word + " ";

}

}

// Extract and reverse the last word in the string.

word = "";

for (j = 0; j <= end; j++) {

word = word + input.charAt(j);

}

result += word;

return result;

}


public static void main(String[] args) {

String input = "Helo I am Aadil";

int end = input.length() - 1;

int start = 0;

int j = 0;

// Call the reverseString function to reverse the input string.

String reversed = reverseString(end, start, j, input);

// Print the reversed string.

System.out.println("Reversed String: " + reversed);

}

}



Comments

Popular posts from this blog

Block vs Inline Elements In HTML

  Block: Block element always start in New Line  Block element always start in new line occupy complete width available  Example: h2, p, div Inline Element: They do not start in new line occuply width as much required  Example: img, anchor a,span There are no different between div and span, only difference is div is block element and span is Inline, it will help you to group your content or elements

Time Complexity

What is time complexity ? Ans: Time complexity not a run time of a code, its totally depends on system configuration, processor, server , input size will increase time complexity. Time complexity ko likhne ke tarike jo hote hai use notation kehte hai. Notation is basically symbol NOTATION OF COMPLEXITY Best Case: kam se kam time me chla gya code best case hota hai Ω (Omega) Ω(1) se likhte hai Average Case: Ek average time jisme code chle  Θ(n+1)/2 Worst Case: Worst case ka mtlb kuch bhi ho jaye is time ko ye exceed nhi kregea O(n) Nested Loop me Time Complexity multiply hoti hai aur n^2 banti hai Wahi Do different loops me N+M hoti hai jisme jiski sabse bdi value hai wo big of O me jati hai O(1) - Constant Time: Operations that take a constant amount of time, regardless of the size of the input data. O(log n) - Logarithmic Time: Algorithms that have a logarithmic time complexity, often seen in binary search or certain tree-based algorithms. This is best time Complexity this i...

Find Unique Number in Array Java , XOR

 Question:  WAP to find unique number in Array Java package aRray ; import java . util .*; public class practicalArray { public static void main ( String [] args ) { Scanner scan = new Scanner ( System . in ) ; // Step 1: Input size of the array from the user int size = scan . nextInt () ; // Step 2: Create an integer array of the specified size int [] arr = new int [ size ] ; // Step 3: Initialize 'res' with the first element of the array int res = arr [ 0 ] ; // Step 4: Loop to read array elements and find the unique number for ( int i = 1 ; i < size ; i ++ ) { // Read an integer from the user and store it in the array arr [ i ] = scan . nextInt () ; // Step 5: Use XOR (^) operation to find the unique number res = res ^ arr [ i ] ; } // Step 6: Print the unique number System . out . print...